Can't get SMB file sharing server to work on Windows 10

ElPaul0

Junior Member
Local time
11:13 AM
Posts
1
Location
France
Thread starter
Hi beautiful people.
I finally got really tired of wandering around the whole Internet hoping to find what's wrong with my server, and got there to show in details my problem.

The concept of my rig is a server that combines applications server, remote desktop server and file sharing server. It's a kind of "one computer for the whole family" concept. By "application server" and "remote desktop server" I mean a sever that you connect to using Microsoft Remote Desktop from any thin and light laptop witch a decent internet connection, upon witch you can achieve some serious work like video editing or even gaming. And the server is flanked witch 4 big HHDs running in raid 5 with a nice raid controller board, to work just like a NAS. That is the whole concept of this server.

At first I built it, pretty nicely, in a 3U bay that I pretty much destroyed with power-tools in order to fit the giant gtx1070 inside.

Then I installed Windows Server 2019, and that went pretty smoothly: with only a few clicks on the server manager interface, I configured the application server, set up the remote desktop accesses for all the different users, and configured the file sharing server.

The file sharing server worked just fine: it was a SMB share witch i could access to from any computer connected to internet, using the "map a new network drive" tool, entering the Global IP address of the server's router (79.90.XXX.X3) followed by the name of the SMB share, and finally entering my server user credentials.

1634040965339.png

(Yes i'm French, i'm pretty sure it won't be a big deal for most of you, the buttons and options are exactly the same as in English)

I just had a few things to set up on my router: setting a static IP on my server MAC address, then redirect the 445 port on the 445 port, and that was pretty much it. It worked very fine and was even able to reach some pretty high write speeds like 150 Mbytes/s over the internet.

1634041175206.png



Then the problems that I encountered came from the application server: i figured out that a lot of programs or games that i wanted to run on the server couldn't install on Windows server. I was able to mod some of them to install them anyway but it was a lot of work for each, and some of them just couldn't run at all.

So what I did was to get rid of Windows server: instead of using windows server to try to run some Windows 10 programs, I installed windows 10 and modded it a bit to add to it some of the features of windows server.

I modded the termsrv.dll and regedit to allow multiple RDP users at the same time and even several accounts for one user, that worked perfectly: the application server is done.

But the real problem comes from the file share: it just can't get the SMB share to work again like it did with windows server.
The method i tried to get working was to select the file that i want to share on the raid, go to share, and share it the exact same way as Windows Server.

One important thing: IT WORKS IN LAN! It totally works, exactly the way that it did when it was on windows server. It doesn't anywhere else: the network drive becomes unavailable as long as it's away from the local network on witch the server is. So this makes me feel like the problem comes from the router, or maybe the authorizations or I don't know, but not from the SMB or the share itself. But why wouldn't it work over the internet while working in LAN despite the fact that it worked over the internet with windows server and that i didn't change the router settings ever since?

I ran across lots of details like:
-turn on the SMB in turn on / off windows functionalities
-set my connection as private network
-check if my global IP address from the router hasn't changed, due to the fact that i haven't set up a DynDNS (it actually never changes so i stopped using NoIP or DynDNS solutions that are a pain in the *** to maintain each month, and just used the actual IP address since)
-allow password protected share in the control panel
-set up authorizations for each user to access to the share

1634042086028.png


Do you guys thing of one thing that I could have forgotten? One thing that would make Windows 10 and Windows server behave differently regarding SMB share over the internet?

I know that some other solutions exist, like filezilla or other FTP / SFTP shares, but i really would like to keep it as simple as it can get, using the default way of sharing file from Windows, not some external and proprietary solution.

I hope that someone could help me ;)
Many thanks to you all,
Paul
 
Windows Version
Windows 10 (build 19043)

My Computer

System One

  • Operating System
    Windows 10
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 3600X
    Motherboard
    Aorus B450 Elite
    Memory
    DDR4 32Gb 3000MHz CL15
    Graphics Card(s)
    Nvidia Geforce 1070
    Monitor(s) Displays
    Very very crappy monitor that has epilepsy triggering hasards
    Cooling
    Lots of fans ;)
    Mouse
    Insanely old apple mouse
    Internet Speed
    1ms 990 down 600 up
Top